Results 1 to 5 of 5

Thread: Aprilia SR50 Starter Switch Question

  1. #1
    Senior Member Moderator Jmetz's Avatar
    Join Date
    Dec 2002
    Location
    Denver
    Posts
    4,707

    Aprilia SR50 Starter Switch Question

    I bought a not running Aprilia SR50 and it seems that there is no power getting to the starter. I've checked the relay and it tests good. When I push the start button I get no sound from the relay which tells me (if I'm correct) there is a break between the button and the relay. I opened up the control to have a look (everything else on the control works). To be honest I'm not terribly sure what to expect here. I see the spring that the button is attached to and I feel like there should be a pin or something in the spring that makes contact? I'm attaching a picture of the switch open and closed.



    I've got more flavor than a packet of macaroni.

  2. #2
    I'm pumped... Let's let the healing begin! Lifetime Supporter ~Barn~'s Avatar
    Join Date
    Nov 2002
    Location
    Lone Tree
    Posts
    17,640

    Re: Aprilia SR50 Starter Switch Question

    Clean. Reinstall. Try again.
    ~Brandon~
    Aprilia RSV 1000 R Factory - "Gemma"
    MV Agusta F3 675 - "Amy Lou"
    (720)935-6438
    I rarely think of motorcycles without a little yearning. They are about moving, and humans, I think, yearn to move its in our cells, in our desires. We quiet our babies with cyclic movement, and we quiet ourselves by going.
    Melissa Holbrook Pierson

  3. #3
    Senior Member Moderator Jmetz's Avatar
    Join Date
    Dec 2002
    Location
    Denver
    Posts
    4,707

    Re: Aprilia SR50 Starter Switch Question

    So further to that end I took the switch out of the control and jumped the 2 lead solder points on the back of the switch with pliers. I'm assuming that if power were present it would bypass the switch and engage they relay and the starter, would that be correct? Obviously that is not what happened.
    I've got more flavor than a packet of macaroni.

  4. #4
    Senior Member Moderator Jmetz's Avatar
    Join Date
    Dec 2002
    Location
    Denver
    Posts
    4,707

    Re: Aprilia SR50 Starter Switch Question

    So I am correct and did get it to fire by jumping the leads on the back of the switch. It seems that for some reason the switch itself is not making contact.
    I've got more flavor than a packet of macaroni.

  5. #5
    Senior Member birchyboy's Avatar
    Join Date
    Sep 2010
    Posts
    1,576

    Re: Aprilia SR50 Starter Switch Question

    Quote Originally Posted by ~Barn~ View Post
    Clean. Reinstall. Try again.
    Yeah, that switch is super dirty. Give it a good cleaning.

Similar Threads

  1. The HPR switch to MotorsportReg.com
    By The GECCO in forum Track Days & Mini Moto Racing
    Replies: 4
    Last Post: Sun Apr 21st, 2013, 09:23 AM
  2. Any switch experts?
    By Ezzzzy1 in forum Non-Bike Discussion
    Replies: 17
    Last Post: Fri Mar 30th, 2012, 09:38 AM
  3. Aprilia question
    By ton-up-boy in forum Bike Tech
    Replies: 8
    Last Post: Fri Mar 11th, 2011, 11:06 AM
  4. Starter Question
    By Matrix in forum Bike Tech
    Replies: 4
    Last Post: Fri May 23rd, 2008, 09:28 AM
  5. 97 yzf750 ign. switch question
    By derekm in forum Bike Tech
    Replies: 0
    Last Post: Mon Jun 4th, 2007, 04:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •